[milters] Archive

Lists Index Date Thread Search

Article: 1305
From: David Jones
Date: 2011-01-12 08:42:26 -0500
Subject: RE: rcpt_host='' is not a defined route, skipping

Thanks.  The problem was the milter-greylist addition of the invalid macros in the second
link below.

My searches through the list archives didn't find this article.  Maybe now they will with
this post.  :)

-----Original Message-----
From: milters@milter.info [mailto:milters@milter.info] On Behalf Of Anthony Howe
Sent: Wednesday, January 12, 2011 7:08 AM
To: milters@milter.info
Subject: [milters] Re: rcpt_host='' is not a defined route, skipping

On 12/01/2011 12:57, David Jones whispered from the shadows...:
> I am getting this line in my maillog constantly with no other 
> milter-ahead logging.  What is wrong with my configuration or 
> installation?
> 
> milter-ahead[4119]: 51939 p08IkfO9019081: rcpt_host='' is not a 
> defined route, skipping
> 
> Does this mean milter-ahead is not getting the rcpt_host value passed 
> to it from sendmail?

This have been previously covered:

http://www.snertsoft.info/lists/article.php?l=milters&d=2010-02&f=314

Also check that the default list of macros given to a milter by sendmail hasn't been
changed, ie. dropped {rcpt_host}:

http://www.snertsoft.info/lists/article.php?l=milters&d=2006-06&f=959

-- 
Anthony C Howe            Skype: SirWumpus                  SnertSoft
                        Twitter: SirWumpus      BarricadeMX & Milters
http://snert.com/      http://nanozen.info/     http://snertsoft.com/


Lists Index Date Thread Search