[milters] Archive

Lists Index Date Thread Search

Article: 243
From: Quentin Campbell
Date: 2010-01-19 04:17:28 -0500
Subject: Is this the right place for a question about a WIMP problem?

Anthony

Thought I would give your new light weight MLM 'WIMP' a trial. However any message submission for a list done via sendmail is failing with the following sort of message being logged:

Jan 19 08:16:04 cheviotdb sendmail[30064]: o0J8G4ss030064: from=<root@extmon.ncl.ac.uk>, size=1419, class=0, nrcpts=1, msgid=<201001190815.o0J8Fwl2028466@extmon.ncl.ac.uk>, proto=ESMTP, daemon=MTA, relay=cheviot10.ncl.ac.uk [128.240.234.10]

Jan 19 08:16:04 cheviotdb sendmail[30065]: o0J8G4ss030064: to="|/usr/local/sbin/wimp list-name=wimp-test", ctladdr=<wimp-test@cheviotdb.ncl.ac.uk> (8/0), delay=00:00:00, xdelay=00:00:00, mailer=prog, pri=31630, dsn=4.0.0, stat=Deferred: prog mailer (/usr/sbin/smrsh) exited with EX_TEMPFAIL

The /etc/aliases file entry for my test list (wimp-test) as you will see from the log record is:

 wimp-test:      "|/usr/local/sbin/wimp list-name=wimp-test"

I am running WIMP on a 64-bit CentOS 5.3 box. The sendmail.cf file uses /usr/sbin/smrsh as the 'prog' mailer. I thus have in /etc/smrsh

  lrwxrwxrwx 1 root root 20 Jan 18 16:51 wimp -> /usr/local/sbin/wimp  

I have '+verbose' set in /var/wimp/wimp-test/config but am not seeing any verbose logging in /var/log/maillog.

I suspect I have missed something simple in my setup but cannot see it myself!

Thanks

Quentin
---
------------------------------------------------------------------------



Lists Index Date Thread Search