[milters] Archive

Lists Index Date Thread Search

Article: 1896
From: Anthony Howe
Date: 2008-10-02 04:39:10 -0400
Subject: Re: milter-ahead 1.9

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

Denis Anthony Dowling uttered...:
> We have been using milter-ahead 0.9 for some years now without
problems. Recently we decided to upgrade our mail gateway and the
software (including milter-ahead) installed on it. However, we
configured milter-ahead (1.9) in the same manner as 0.9 but it does not
seem to work; all messages (including invalid recipients) are accepted.
I enabled debugging (see below) and everything seems to be working fine.
> 

Actually the milter debugging output would be more useful than
sendmail's debug output.

	milter-ahead -restart verbose=info,db,dialog

Also do some of your systems/domains use catch-all addresses? If so
then, stop milter-ahead, delete the cache, set -is-blind-mx, restart.

Also do you have Exchange servers or similar that do not report RCPT
failures during the SMTP session? If so see the SnertSoft FAQ about
"Fronting for Exchange Server".

As an aside, catch-all addresses are a bad idea, but that is a separate
argument.

-- 
Anthony C Howe        Twitter: SirWumpus                    SnertSoft
+33 6 11 89 73 78       Skype: SirWumpus        BarricadeMX & Milters
http://www.snert.com/     ICQ: 7116561
     http://www.snertsoft.com/

Lists Index Date Thread Search