[milters] Archive

Lists Index Date Thread Search

Article: 909
From: Taylor, Grant
Date: 2006-05-03 13:17:11 -0400
Subject: Milter-Report v0.8 Strange Behavior...

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

(I'm starting a new thread for this issue b/c it is for the newer version of Milter-Report
v0.8.)

After upgrading Milter-Report to v0.8 I now successfully receive complete (read: non
truncated) reports for recipients that fill the buffer.  However I am still having an
issue with not receiving reports for recipients that I KNOW had mail rejected.  To test
things and be sure I sent my self an email with the SpamAssassin GTUBE test string to trip
milter-spamc which is configured to reject emails that are a specified amount over each
users SA required spam score.  As expected the emails did not come in and I did find
entries in the logs that indicated that milter-spamc rejected the test emails.  However I
did not receive a report for the user that I sent the successfully rejected message to. 
On the other hand I have occasionally received reports for users other than the one user
that keeps filling the buffer.  One day I'll get the reports like I expect, other days I
will not, and then out of the blue I will get them again.

I am very happy with what Milter-Report provides and would love to continue using it.  If
there is any insight that any one could provide I'd greatly appreciate it.  I'm also
willing (Anthony) to turn up logging for milter-report to the highest level, sanitize it
and send it to you if that would help you track things down.  However I'd like to not log
an extra 10 - 100 MB for the test time frame if I don't need to.  As of thus far I have
not seen any thing to indicate that there are any errors that I can correct on my end.



Grant. . . .

Lists Index Date Thread Search