[milters] Archive

Lists Index Date Thread Search

Article: 3796
From: Anthony Howe
Date: 2013-11-25 18:27:30 -0500
Subject: Re: Compiline libsnert on debian wheezy

On 25 Nov 2013 14:22, G√ľnter Grodotzki squeaked in a girly voice...:
> Hello,
> 
> I can't configure libsnert. It will endless loop into:
> 

> checking for db.h in /usr/local/include/db-4.7... no

> configure: getting package libdb5.1-dev...
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> libdb5.1-dev is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> configure: getting package libdb5.1-dev... done

This is because the currently available libsnert has a hardcoded list of
version numbers in the configure.in file used to generate configure
script. The BDB 5.1 is newer than the current release. I have a newer
libsnert (not yet released), which fixes the issue of new BDB releases.
However, it requires updating all the  milter tar balls to use it.

If you have the autoconf package installed, you can edit libsnert's
configure.in to add 5.1 to the search list. Then simply configure again,
which will detect the change and invoke autoconf to update itself, then
do the configuration.

Alternatively, contact me off list and I'll make arrangements for access
to the more recent versions.

(Yes AlexB, I know I'm way behind on updates.)

-- 
Anthony C Howe            Skype: SirWumpus                  SnertSoft
                        Twitter: SirWumpus      BarricadeMX & Milters
http://snert.com/      http://nanozen.info/     http://snertsoft.com/

Lists Index Date Thread Search