[milters] Archive

Lists Index Date Thread Search

Article: 3733
From: Anthony Howe
Date: 2013-09-11 09:17:09 -0400
Subject: Re: Compiling libsnert on debian wheezy fails

On 9 Sep 2013 11:09, S y s C o / hosting uttered from a behind a tree...:
> Hi,
> 
> libsnert won't compile on Debian 7 "Wheezy", because it only have libdb5
(5.1) and the /usr/local/src/com/snert/src/lib/include/berkeley_db.h file contains:
> 
>> #if   DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1

Replacing the above line with

#if   DB_VERSION_MAJOR >= 5
# define DBTXN          (DB_TXN *) 0,
# define DBTXN_ROAR     (DB_TXN *) 0,
#elif DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1

should solve the issue.

-- 
Anthony C Howe            Skype: SirWumpus                  SnertSoft
                        Twitter: SirWumpus      BarricadeMX & Milters
http://snert.com/      http://nanozen.info/     http://snertsoft.com/

Lists Index Date Thread Search