[milters] Archive

Lists Index Date Thread Search

Article: 909
From: Anthony Howe
Date: 2010-07-19 12:41:54 -0400
Subject: Re: milter-ahead with Debian Testing

On 17/07/2010 13:23, Jon Rowlan whispered from the shadows...:
> Hi all,
> 
> I am working with Debian Testing (Squeeze) and sendmail 8.14.3 and
> milter-ahead 1.1
> 
> I am having a problem getting the correct LIBS definition to build
> milter-ahead.

Have you considered downloading updates to libsnert and milter-ahead.
Your license entitles you to updates.

> The result of ./configure gives ...
> 
> LibSnert/1.61.829
> Copyright 1996, 2006 by Anthony Howe. All rights reserved.
> 
>   Platform..........: Linux gcc
>   pthread & mutex...: yes yes
>   Semaphore.........: SYSTEMV_API
>   Shared Memory.....: SYSTEMV_API
>   Time..............: POSIX_API
>   Berkeley DB.......: 4.8
>   libmilter.........: required

Its not detecting the libmilter library and/or headers on this system.
You probably have to install the sendmail-devel package. Or maybe
libmilter-devel. (I never understand how or why these things are
separate from the binaries.)

>   CFLAGS............: -D_REENTRANT -O2 -Wall -I${top_srcdir}/../../
>   LDFLAGS...........: -L${top_srcdir}/../../lib
>   LIBS..............: -lpam -lrt -lpthread -ldb-4.8 -ldl

-- 
Anthony C Howe            Skype: SirWumpus                  SnertSoft
+33 6 11 89 73 78       Twitter: SirWumpus      BarricadeMX & Milters
http://snert.com/      http://nanozen.info/     http://snertsoft.com/

Lists Index Date Thread Search