[milters] Archive

Lists Index Date Thread Search

Article: 525
From: Edda
Date: 2010-05-11 17:14:40 -0400
Subject: milter-ahead not starting on debian

Hi,

we've just compiled the milter-ahead 1.11.140. It's not starting on
Debian 4.0.

config:
testinst:/usr# cat /etc/mail/milter-ahead.cf
#access-db=/etc/mail/access.db
run-group=milter
run-user=milter
verbose=debug,libmilter,cache,dialog,socket-all,db,trace,state



With access-db line the message is:

milter-ahead[4166]: failed to open "/etc/mail/access.db"

Without this line error message is always:

milter-ahead[3118]: failed to create cache


strace doesn't give any hints to me:
[...]
uname({sys="Linux", node="testinst", ...}) = 0
brk(0)                                  = 0x8101000
brk(0x8124000)                          = 0x8124000
open("/etc/mail/milter-ahead.cf", O_RDONLY) = 3
fcntl64(3, F_GETFD)                     = 0
fcntl64(3, F_SETFD, FD_CLOEXEC)         = 0
fstat64(3, {st_mode=S_IFREG|0644, st_size=228, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb7ef6000
read(3, "#access-db=/etc/mail/access.db\nru"..., 4096) = 228
read(3, ""..., 4096)                    = 0
close(3)                                = 0
munmap(0xb7ef6000, 4096)                = 0
clone(Process 3563 attached
child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0xb7d61908) = 3563
[pid  3563] setsid()                    = 3563
[pid  3563] time(NULL)                  = 1273605008
[pid  3563] open("/etc/localtime", O_RDONLY) = 3
[pid  3563] fstat64(3, {st_mode=S_IFREG|0644, st_size=2309, ...}) = 0
[pid  3563] fstat64(3, {st_mode=S_IFREG|0644, st_size=2309, ...}) = 0
[pid  3563] mmap2(NULL, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7ef6000
[pid  3563] read(3,
"TZif2\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\10\0\0\0\10\0\0\0\0\0"...,
4096) = 2309
[pid  3563] _llseek(3, -28, [2281], SEEK_CUR) = 0
[pid  3563] read(3, "\nCET-1CEST,M3.5.0,M10.5.0/3\n"..., 4096) = 28
[pid  3563] close(3)                    = 0
[pid  3563] munmap(0xb7ef6000, 4096)    = 0
[pid  3563] stat64("/etc/localtime", {st_mode=S_IFREG|0644,
st_size=2309, ...}) = 0
[pid  3563] socket(PF_FILE, SOCK_DGRAM, 0) = 3
[pid  3563] fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
[pid  3563] connect(3, {sa_family=AF_FILE, path="/dev/log"...}, 110) = 0
[pid  3563] send(3, "<19>May 11 21:10:08 milter-ahead["..., 63,
MSG_NOSIGNAL) = 63
[pid  3563] exit_group(1)               = ?
Process 3563 detached
--- SIGCHLD (Child exited) @ 0 (0) ---
exit_group(0)                           = ?


It looks much like a permissions problem but I've no idea what we've
configured wrong.

Can you give a hint?

Thanks in advance,
Edda







Vorstand: Dr. Joerg Posewang (Vorsitz), Dr. Roland Kaltefleiter, Andreas Seeger
Aufsichtsrat: Detlev Huebner (Vorsitz)
Sitz der AG: Kiel, HRB 5358 USt.ID: DE156073942

Diese E-Mail enthaelt vertrauliche oder rechtlich geschuetzte Informationen.
Das unbefugte Kopieren dieser E-Mail oder die unbefugte Weitergabe der
enthaltenen Informationen ist nicht gestattet.

The information contained in this message is confidential or protected by
law. Any unauthorised copying of this message or unauthorised distribution
of the information contained herein is prohibited.


Lists Index Date Thread Search