[milters] Archive

Lists Index Date Thread Search

Article: 263
From: Anthony Howe
Date: 2010-01-20 06:57:30 -0500
Subject: Re: LibSnert and Milter-report

On 19/01/2010 21:19, Rick Knight whispered from the shadows...:
> I am still trying to install Milter-report on my sendmail server. I have
> built and installed LibSnert and Milter-report. I have created the
> folders for the unix socket, pid file and cache file. I have set
> permissions on those folders. When I start Milter-report nothing
> happens. No unix socket or pid file is created. Cache folder is empty.
> Ps -w aux | grep milter-report shows nothing running. What am I doing
> wrong? How can I get Milter report to work on my system?

1. Try
	milter-report -help

You should get output to standard out.

2. Have you placed a milter-report.cf in /etc/mail?

	# cd /etc/mail
	# milter-report -help >milter-report.cf
	# vi milter-report.cf 		(review/edit options)

Note on Linux milter-report lives in /usr/local/sbib while *BSD system
it lives in /usr/local/libexec.

3. Start milter report

	# milter-report -restart verbose=warn,info,db ; tail -f /var/log/maillog

Does milter-report log anything in the maillog? Typically if it can't
start, it is reported in the maillog.

4. You have noted that you are using the lates libsnert 1.73.4, which is
good.


-- 
Anthony C Howe            Skype: SirWumpus                  SnertSoft
+33 6 11 89 73 78       Twitter: SirWumpus      BarricadeMX & Milters
http://snert.com/      http://nanozen.info/     http://snertsoft.com/

Lists Index Date Thread Search