[milters] Archive

Lists Index Date Thread Search

Article: 1980
From: Rob McMahon
Date: 2009-03-24 06:51:44 -0400
Subject: Re: milter-ahead 1.4 and Debian Lenny (v5)

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

Jon Rowlan wrote:
> Removal...........: milters-request@milter.info?subject=remove
> More information..: http://www.milter.info/#Support
> --------------------------------------------------------
>
>   
>> When I've had "Invalid argument" problems with programs reading
>>     
> sendmail=20
>   
>> databases, it's normally been because of a mismatch in the version of=20
>> BerkeleyDB between the program that created the database and the one=20
>> trying to read it. (running makemap from an older version of sendmail=20
>> for instance).
>>     
>
>   
>
> Now that could make sense Rob.
>
> I am now running sendmail 8.14.3 as part of the distro upgrade from 8.13
>
> How do I tell which version of BerkelelyDB my version of sendmail is
> built with?
>
> Any ideas?
>
>   
On Solaris that would be
 > ldd /usr/lib/sendmail /usr/local/libexec/milter-ahead | fgrep libdb
    libdb-4.3.so =>     /usr/local/BerkeleyDB/lib/libdb-4.3.so
    libdb-4.3.so =>     /usr/local/BerkeleyDB/lib/./libdb-4.3.so
or
 > dump -Lv /usr/lib/sendmail /usr/local/libexec/milter-ahead | fgrep libdb
[2]    NEEDED          libdb-4.3.so
[7]    NEEDED          libdb-4.3.so

I'm afraid I don't know what the equivalent on Debian is.  I think it 
has dump / elfdump ?

Rob

-- 
E-Mail:	Rob.McMahon@warwick.ac.uk		PHONE:  +44 24 7652 3037
Rob McMahon, IT Services, Warwick University, Coventry, CV4 7AL, England


Lists Index Date Thread Search