[milters] Archive

Lists Index Date Thread Search

Article: 1954
From: Denis Beauchemin
Date: 2009-02-19 15:24:54 -0500
Subject: milter-limit won't start

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

Hello,

I installed milter-limit on a new RHEL 5.3 box and it refuses to start,=20
giving the following error in maillog:
Feb 19 13:53:57 smtptest milter-limit[2374]: failed to open=20
"/etc/mail/access.db"

I checked all path elements and all are readable. I even changed=20
access.db mode to 644 to no avail.

If I send an email to that server, milter-limit kicks in:
Feb 19 13:36:56 smtptest sendmail[963]: n1JIaug5000963: Milter=20
(milter-limit): local socket name
/var/run/milter/milter-limit.socket unsafe
Feb 19 13:36:56 smtptest sendmail[963]: n1JIaug5000963: Milter=20
(milter-limit): to error state
Feb 19 13:36:56 smtptest sendmail[963]: n1JIaug5000963: Milter: connect=20
to filters
Feb 19 13:37:08 smtptest sendmail[963]: n1JIaug6000963: Milter accept:=20
message

The first log line above mentions an unsafe local socket.  Is this=20
important? If so, how could I correct this?

I tried to strace /usr/local/sbin/milter-limit but couldn't find=20
anything useful in the output.

Thanks for any help!

Denis

--=20
   _
  =B0v=B0   Denis Beauchemin, analyste
 /(_)\  Universit=E9 de Sherbrooke, S.T.I.
  ^ ^   T: 819.821.8000x62252 F: 819.821.8045



Lists Index Date Thread Search