[milters] Archive

Lists Index Date Thread Search

Article: 1953
From: <ivan@zilic.net>
Date: 2009-02-17 18:26:24 -0500
Subject: milter-spamc not connecting to SPAMD

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

Hi!

I ve been using milter-spamc for some years now and never had a =20
problem. But now something is happening. For some reason, milter-spamc =20
wont connect to spamd.

Spamd is running and accepting connections at port 783.

I will paste pieces of my log:

This is me connecting from telnet

Feb 17 19:59:14 localhost spamd[5623]: spamd: connection from =20
localhost.localdomain [127.0.0.1] at port 42040
Feb 17 19:59:15 localhost spamd[5623]: spamd: bad protocol: header =20
error: at /usr/bin/spamd line 2001, <GEN13> line 1.
Feb 17 19:59:15 localhost spamd[5619]: prefork: child states: II


this is milter-spamc trying to connect to spamd

Feb 17 19:59:10 localhost milter-spamc[5703]: 00124 n1HMx8805704: =20
filterEndMessage(8069980)
Feb 17 19:59:10 localhost milter-spamc[5703]: enter =20
SocketOpenTcpClientWait(127.0.0.1, 783, 120000)
Feb 17 19:59:10 localhost milter-spamc[5703]: enter SocketOpen(412787ac, 2)
Feb 17 19:59:10 localhost milter-spamc[5703]: SocketOpen() socket() fd=3D6
Feb 17 19:59:10 localhost milter-spamc[5703]: exit =20
SocketOpen(412787ac, 2) Socket=3D806a670 fd=3D6
Feb 17 19:59:10 localhost milter-spamc[5703]: enter SocketClose(806a670)
Feb 17 19:59:10 localhost milter-spamc[5703]: SocketGetError(806a670) =20
s->fd=3D6 errno=3D0 s->error=3D0
Feb 17 19:59:10 localhost milter-spamc[5703]: SocketClose() close(6) =20
rc=3D0 errno=3D0
Feb 17 19:59:10 localhost milter-spamc[5703]: exit SocketClose(806a670)
Feb 17 19:59:10 localhost milter-spamc[5703]: exit =20
SocketOpenTcpClientWait(127.0.0.1, 783, 120000) Socket=3D0
Feb 17 19:59:10 localhost milter-spamc[5703]: 00124 n1HMx8805704: =20
failed to connect to spamd 127.0.0.1,783


I tried to watch the comunication between milter & spamd using tcpdump =20
and there is no trafic at all from milter to spamd.

I am totally out of ideas.

Versions are:

Feb 17 19:51:08 localhost milter-spamc[2103]: =20
parseCfAccessFile(Kaccess hash /etc/mail/access.db)
Feb 17 19:51:08 localhost milter-spamc[2103]: accessFile=3D/etc/mail/access.=
db
Feb 17 19:51:08 localhost milter-spamc[2103]: process uid=3D51 gid=3D51
Feb 17 19:51:08 localhost milter-spamc[2103]: milter-spamc/0.25.321 =20
Copyright 2003, 2004 by Anthony Howe. All rights reserved.
Feb 17 19:51:08 localhost milter-spamc[2103]: LibSnert/1.40.622 =20
Copyright 1996, 2004 by Anthony Howe. All rights reserved.
Feb 17 19:51:08 localhost milter-spamc[2103]: Sendmail libmilter =20
Protocol version 2
Feb 17 19:51:08 localhost milter-spamc[2103]: Sleepycat Software: =20
Berkeley DB 4.0.14: (November 18, 2001)
Feb 17 19:51:08 localhost milter-spamc[2103]: milter-spamc: Opening =20
listen socket on conn unix:/var/lib/milter-spamc/socket


Telnet port 783 results

telnet 127.0.0.1 783
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

SPAMD/1.0 76 Bad header line:
Connection closed by foreign host.

This same setup (same versions of everything) was working for years. =20
And now i am having problems.

I hope someone can help me.

My problem looks exactly like this one: =20
http://www.snert.com/Software/ecartis/index.php?go=3D/milters/2005-04/487

Thanks in advance.
=C2=A0

Ivan =C5=BDili=C4=87 Schmidt
+56-2-656 72 32
----------------------------------------------------------------
This message was sent using www.MainMail.net and its virus free.
Virus database was updated Feb 17 19:01 GMT -0400
Antivirus definitions are now recognizing 1631969 viruses.

Lists Index Date Thread Search