[milters] Archive

Lists Index Date Thread Search

Article: 1448
From: Donald Wheaton
Date: 2007-02-21 14:07:44 -0500
Subject: smfi_register() failed

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

I've been running older versions of milter-gris and milter-date for some
time.  I decided it was time to do some updating, so I started with my
backup mail server which is running Fedora Core 1 and Sendmail 8.14.0.  When
I originally installed milter-gris and milter-date, I was running Sendmail
8.12.x.

I am trying to install milter-date 0.20.197 and milter-gris 0.19.104 with
LibSnert 1.62.834.  Everything seems to build and install OK, but when I try
to start either the milter-gris or milter-date service, I get the similar
messages in my sendmail log and the services fail to start:

smfi_register: version mismatch application: 4 != milter: 16777216
smfi_register: version mismatch application: 3 != milter: 16777216
smfi_register: version mismatch application: 2 != milter: 16777216
smfi_register() failed

I was able to revert back to my previous installation without recompiling,
because I saved my old build directories.  This previous installation
generates these sendmail log messages when the services start:

smfi_register: version mismatch application: 4 != milter: 2
smfi_register: version mismatch application: 3 != milter: 2
process ruid=0 rgid=585 euid=614 egid=585
milter-date/0.13.181 Copyright 2003, 2005 by Anthony Howe. All rights
reserved.
LibSnert/1.45.728 Copyright 1996, 2005 by Anthony Howe. All rights reserved.
libmilter version 2 (4)
Sleepycat Software: Berkeley DB 4.1.25: (October 24, 2003)


The 16777216 (2^24) number for the libmilter version looks suspicious.

Does anyone have any ideas or suggestions?



Lists Index Date Thread Search