[milters] Archive

Lists Index Date Thread Search

Article: 1159
From: Ken A
Date: 2006-09-29 19:58:21 -0400
Subject: Re: milter-link issue

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------



Anthony Howe wrote:
> Removal...........: milters-request@milter.info?subject=remove
> More information..: http://www.milter.info/#Support
> --------------------------------------------------------
> 
> Ken A wrote:
>> Using milter-link version 0.2.13 / LibSnert 1.61
>>
>> I've noticed a issue where milter-link began ignoring it's whitelist 
>> access db. Not sure what caused it, but a restart fixed it. I see there 
> 
> Check file permissions & ownership. When you restart the milter it 
> starts as root, opens its .pid and the access.db, then changes ownership 
> to milter:milter. Subsequent updates of access.db will be detected and 
> reopened only if process as milter:milter can read access.db. The 
> symptom you describe would indicate that access.db has permission and/or 
> ownership problems.
> 

I use access-db=/etc/mail/milter-link-access.db in the command line and

-rw-r--r--  1 root root  49152 Sep 28 15:49 milter-link-access.db

it's readable.

Does milter link also require access to sendmail's access.db ?
sendmail's access.db has other functions, so I like to keep the two 
separate. Is this perhaps an issue?

Thanks,
Ken A
Pacific.Net

Lists Index Date Thread Search