[milters] Archive

Lists Index Date Thread Search

Article: 612
From: Anthony Howe
Date: 2005-06-10 05:33:32 -0400
Subject: Re: milter-sender giving "smfi_register: version mismatch"

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

Jeff Groves wrote:
> I'm not exactly sure what milter-sender is trying to tell me:
> Jun  9 05:05:44 hoover milter-sender[3214]: milter-sender: 
> smfi_register: version mismatch application: 4 != milter: 2
> Jun  9 05:05:44 hoover milter-sender[3214]: milter-sender: 
> smfi_register: version mismatch application: 3 != milter: 2
> 
> 
> This is occurring when I start-up milter-sender.  It seems to run just 
> fine even with these warnings.
> 
> Any idea what this is?

When you start one of the milters you now see log lines like:

milter-NAME: smfi_register: version mismatch application: 4 != milter: 2
milter-NAME: smfi_register: version mismatch application: 3 != milter: 2

These messages are normal and are generated by libmilter's 
smfi_register() function. They are only warnings. Libmilter does not 
provide an API to query the version of the libary at runtime. Some of 
the SnertSoft milters, like milter-cli, use recent libmilter extensions 
and need to know if libmilter was compiled with those extension enabled. 
The above messages are generated when the smfMainStart() tries to 
discover the version of libmilter through repeated calls to 
smfi_register().

-- 
Anthony C Howe                                 +33 6 11 89 73 78
http://www.snert.com/       ICQ:
7116561         AIM: Sir Wumpus

"Understanding is a three edged sword." - Kosh, Babylon 5

Lists Index Date Thread Search