[milters] Archive

Lists Index Date Thread Search

Article: 188
From: Gib Gilbertson Jr.
Date: 2004-10-20 02:02:38 -0400
Subject: [SIQ] 027 Re: Re: Sendmail errors

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

Hi.At 10:45 AM 10/19/2004 +0200, you wrote:
>Removal...........: milters-request@milter.info?subject=remove
>More information..: http://www.milter.info/#Support
>--------------------------------------------------------
>
>Gib Gilbertson Jr. wrote:
>
> > I've installed Sendmail 8.13.1 on a test FreeBSD 4.10 box. I have added
> > Milter-ahead, ClamAV-Milter, and FEATURE(`greet_pause',`90000') plus all
> > the usual features, access.db, mailtertable, virtusertable, etc. and 
> ran m4
> > to generate a new sendmail.cf file. I then tried to start Sendmail.
> >
> > After trying to start Sendmail I get an error message as follows:
> >
> > 554 5.0.0 /etc/mail/sendmail.cf: line 591: milter_set_option: invalid
> > Milter option macros.eom
> >
> > I comment out the line in sendmail.cf
> >
> >     O Milter.macros.eom={msg_id}
>
>This does not come from my suggested milter configuration, particularly
>since milter-ahead doesn't need any extra macros other than the defaults.

Any idea where it could have come from? It wasn't in Sendmail 8.12.11 but 
showed up in sendmail.cf after installing Sendmail 8.13.1 and adding the 
FEATURE(`greet_pause',`90000') to the .mc file and then building sendmail.cf.


> > and Sendmail starts fine, and seems to operate as it should. I've done a
> > google search trying to find an answer to this question and can't find any
> > messages stating other people are having this problem.
> >
> > The only thing that doesn't seem to be working is the
> > FEATURE(`greet_pause',`90000'). Could this be related in some way to the
> > problem? Incompatability between Milter-ahead and greet_pause?
>
>No. But make sure you declare
>
>         FEATURE(`greet_pause',`90000')
>
>after
>
>         FEATURE(access_db)
>
>so you should have something like:
>
>         FEATURE(access_db, hash -T<TMPF> /etc/mail/access)
>         FEATURE(`greet_pause', `90000')
>
>This is mentioned in the change log for Sendmail 8.13.1.
>BTW 90 seconds might be just a bit long, especially if you don't use
>have a MSP daemon. You may want to add also to the access database:
>
>GreetPause:127.0.0.1                    0
>GreetPause:your.ip.here                 0
>GreetPause:or.domain.in.ptr             0

This is just a test bed, so I set the pause to 90 seconds to make sure it 
works.. FEATURE(access_db) is ahead of FEATURE(`greet_pause',`90000') in 
the .mc file used for building sendmail.cf.

I didn't put anything into the access db file because I wanted to make sure 
I could verify things were working before applying the modifications to my 
productions server. I don't know if this has anything to do with it but 
here is the output of telnetting to port 25 on the server.

220 xxx.xxx.com ESMTP Sendmail 8.12.11/8.13.1; Wed, 20 Oct 2004 15:58:48 
+1000 (EST)

Is there version number for sendmail correct? I did install sendmail from 
the ports collection, before installing Sendmail 8.13.1 I did a make 
deinstall of Sendmail 8.12.11

Thanks

gib



>--
>Anthony C Howe                                 +33 6 11 89 73 78
>http://www.snert.com/       ICQ:
7116561         AIM: Sir Wumpus
>
>             "Once...we were here."  - Last of The Mohicans


-- 

      Gib Gilbertson Jr.
     Tierramiga Info Systems
      619-287-8647 Support
      http://www.tmisnet.com
      San Diego's "Friendly ISP"



Lists Index Date Thread Search