[milters] Archive

Lists Index Date Thread Search

Article: 156
From: John Poltorak
Date: 2004-10-17 10:06:58 -0400
Subject: [SIQ] 022 Re: Re: milter-bcc

Removal...........: milters-request@milter.info?subject=remove
More information..: http://www.milter.info/#Support
--------------------------------------------------------

On Sun, Oct 17, 2004 at 08:39:33AM -0400, Jeff Groves wrote:
> Removal...........: milters-request@milter.info?subject=remove
> More information..: http://www.milter.info/#Support
> --------------------------------------------------------

I have now got milter-bcc built after correcting two errors. One was due 
to libmilter did not get built and installed correctly, the other was a 
program error in milter-bcc.c which was causing the build to fail for 
libsnert being below v1.41. Not sure how it could work with the current 
release being 1.40. Changing line 86 did the trick for me.

Now to see if I can get it installed and working...


-- 
John


 
> I'm running into this when I build milter-date on RedHat 7.3 as well.  This happens
when you 
> build libsnert in some out of the way place like off of your home directory.
> 
> At one time in the past, I knew how to resolve this, but it's been so long since I
did a 
> fresh build that I've forgotten.
> 
> Basically, the configure script can't find libsnert when it run (even though you're
right 
> there in its directory structure!) and it does not put a proper reference to it in
your make 
> file.
> 
> Run configure again, and you'll see the message that "libsnert is required"
there too. 
> That's actually an error message that means configure could not find libsnert.
> 
> I'll mess around with it a little more today and see if I can remember where to tweak

> configure or the resultant make file.
> 
> Jeff G.
> 
> 
> John Poltorak wrote:
> > Removal...........: milters-request@milter.info?subject=remove
> > More information..: http://www.milter.info/#Support
> > --------------------------------------------------------
> > 
> > 
> > I had my first attempt at building a milter today and managed to get stuck 
> > at an early stage...
> > 
> > In building milter-bcc, I've tried to follow the instructions here:-
> > 
> > http://www.milter.info/milter-bcc/
> > 
> > quite religiously, but make fails for milter-bcc after the other three 
> > steps appear to have run OK
> > 
> > 
> > 4. The build process for libsnert and milter-bcc is pretty straight forward 
> > once you have libmilter installed:
> > 
> > cd (path to)/com/snert/src/lib
> > ./configure
> > make
> > cd ../milter-bcc
> > ./configure
> > make
> > make install
> >  
> > 
> > 
> > I'm using sendmail v8.13.1 which has just been installed so that may 
> > account for the error.
> > 
> > This is the error msg when running make in the milter-bcc dir:-
> > 
> > 
> > gcc -DMILTER_BUILD=`cat BUILD_ID.TXT` -DMILTER_BUILD_STRING='"'`cat 
> > BUILD_ID.TXT `'"' \
> > -Iunknown/include  -D_REENTRANT -I../../include -O2 -Wall -fvolatile
> > -Lunknown/lib  -L../../lib -o milter-bcc milter-bcc.c -ldb-4.2 -lsnert 
> > -lpthread -lrt
> > In file included from milter-bcc.c:81:
> > ../../include/com/snert/lib/mail/smf.h:15:29: libmilter/mfapi.h: No such 
> > file or
> >  directory
> > milter-bcc.c:87:3: #error "LibSnert/1.39 or better is required"
> > make: *** [milter-bcc] Error 1
> > 
> > 
> > Can anyone see what has been overlooked?
> > 
> > 
> 



Lists Index Date Thread Search